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	Little	Navconnect	User	Manual
Version	1.8

Little	Navconnect	is	a	small	free	open	source	application	that	acts	as	an	agent	connecting	Little	Navmap	with	a	flight
simulator	like	FSX,	Prepar3D	and	X-Plane.	This	allows	to	use	Little	Navmap	on	Linux	or	Mac	and	saves	the	the	pain	of
setting	up	remote	SimConnect	links.

More	about	my	projects	at	GitHub.

Copyright	2015-2017	Alexander	Barthel

Last	updated	Thu	Nov	16	2017	15:01:51	GMT+0100	(CET).
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Donations
Donate	to	show	your	appreciation	if	you	like	my	programs.

Spenden	Sie,	um	Ihre	Wertschätzung	zu	zeigen,	wenn	Ihnen	meine	Programme	gefallen.

Donations
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Installation
Note	that	Little	Navconnect	is	bundled	with	the	Little	Navmap	download.

	Highlighted	text		is	used	to	denote	window,	menu,	button,	file	or	directory	names.

Little	Navconnect	for	Windows	is	a	32-bit	application	and	was	tested	with	Windows	7,	Windows	8,	Windows	10	(32-bit	and
64-bit).

The	macOS	and	Linux	versions	are	both	64-bit	and	were	tested	with	macOS	Sierra	and	Ubuntu	Linux.

Updating

Delete	all	installed	files	of	a	previous	Little	Navconnect	version	before	installing	a	new	version.	All	files	from	the	previous
ZIP	can	be	deleted	since	settings	are	stored	in	separate	directories.	In	any	case	do	not	merge	the	installation	directories.

There	is	no	need	to	delete	the	old	settings	directory.	The	program	is	written	in	a	way	that	it	can	always	work	with	old	setting
files.

Windows

Installation	involves	the	simple	copying	of	files	therefore	an	installer	or	setup	program	is	not	required.

Do	not	extract	the	archive	into	the	folder		c:\Program	Files\		or		c:\Program	Files	(x86)\		since	you	will	need	administrative
privileges	in	some	Windows	versions.	Since	Windows	keeps	control	of	these	folders	other	problems	might	occur	like
replaced	or	deleted	files.

Extract	the	Zip	archive	into	a	folder	like		c:\Own	Programs\Little	Navconnect	.	Then	start	the	program	by	double-clicking
	littlenavconnect.exe	.

In	some	cases	you	have	to	install	the	Update	for	Visual	C++	2013	and	Visual	C++	Redistributable	Package.	Install	both	32
and	64	bit	versions.	Usually	this	is	already	installed	since	many	other	programs	require	it.

Other	Simulators	than	FSX	SP2

This	program	was	compiled	using	plain	FSX	SP2	(no	Acceleration)	SimConnect	version	10.0.61259.0.

You	might	have	to	install	an	older	version	of	SimConnect	if	you	use	Prepar3D	or	FSX	Steam	Edition.	If	not	sure	about	this
simply	try	Little	Navconnect	out.	If	it	fails	with	an	error	message	follow	the	instructions	below:

Prepar3D:	In	the	same	directory	as		Prepar3D.exe		is	a		redist\Interface		directory	(normally		C:\Program	Files	(x86)\Lockheed
Martin\Prepar3D	v3\redist\Interface	).	There	are	multiple	legacy	versions	of	SimConnect	available.	You	have	to	install		FSX-SP2-
XPACK.msi		for	Little	Navconnect.

FSX	Steam	Edition:	The	installation	adds	the	folder		C:\Program	Files	(x86)\Steam\SteamApps\common\FSX\SDK\Core	Utilities
Kit\SimConnect	SDK\LegacyInterfaces		where	you	can	find	the	legacy	SimConnect	interfaces.

macOS

Extract	the	ZIP	file	and	copy	the		Little	Navconnect		app	to		Applications		or	any	other	folder.

Linux

Extract	the	tar	archive	to	any	place	and	use	the		littlenavconnect.sh		shell	script	to	start	the	program	from	a	terminal:

	bash	./littlenavconnect.sh	

X-Plane

Installation
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Little	Navconnect	can	only	connect	to	X-Plane	using	the	Little	Xpconnect	X-Plane	plugin	which	has	to	be	installed	too.

The	Little	Xpconnect	plugin	is	included	in	the	Little	Navmap	archive	but	can	also	be	downloaded	separately.	See	the
included		README.txt		in	the		Little	Xpconnect		folder	for	installation	instructions.

The	plugin	is	64-bit	only	and	is	available	for	Windows,	macOS	and	Linux.

General
Little	Navconnect	acts	as	an	agent	that	connects	Little	Navmap	running	on	a	remote	computer	with	a	flight	simulator.	This
saves	the	complexity	of	setting	up	a	remote	SimConnect	link	and	also	allows	using	Little	Navmap	to	connect	remotely	to
the	Little	Xpconnect	X-Plane	plugin.

Little	Navmap	can	connect	to	the	flight	simulator	directly	when	running	on	the	same	computer	as	the	flight	simulator
therefore	the	Little	Navconnect	agent	is	only	needed	for	connecting	to	a	remote	computer.

For	X-Plane	you	need	the	Little	Xpconnect	plugin.

Installation

7

https://albar965.github.io/littlenavmap.html


Usage
You	will	receive	an	error	message	if	the	protocol	of	Little	Navmap,	Little	Navconnect	or	Little	Xpconnect	does	not	match.
Make	sure	to	use	the	latest	versions	of	all	programs	or	use	the	ones	included	in	the	Little	Navmap	download	archive.

Flying	Computer

Install	Little	Navconnect	on	the	flying	computer.	Start	it	and	take	note	of	the	message	that	is	printed	in	the	logging	window.
You	only	need	the	colored	values.	You	can	use	the	IP	address	or	the	hostname.

The	program	will	automatically	connect	to	the	flight	simulator	using	SimConnect,	if	found.	You	can	change	the	connection	to
X-Plane	and	it	will	connect	automatically	to	the	Little	Xpconnect	plugin	if	X-Plane	is	running.	If	no	simulator	was	found	it	will
retry	in	10	second	intervals.

Little	Navconnect	can	print	multiple	IP	addresses	or	hostnames	depending	on	your	network	configuration.	This	can	happen
if	you	have	Ethernet	plugged	in	and	are	connected	using	wireless	LAN	too,	for	example.	You	have	to	try	all	addresses	if	you
are	unsure	which	one	to	use.

Picture	above:	Little	Navconnect	is	running	and	waiting	for	a	flight	simulator.	The		FSX	or	Prepar3D		and		X-Plane		buttons	are
not	shown	on	macOS	and	Linux	or	if	SimConnect	is	not	available.

Change	the	port	in	the		Options		dialog	if	you	see	an	error	message	like	shown	below:

	[2016-07-27	16:45:35]	Unable	to	start	the	server:	The	bound	address	is	already	in	use.	

Client	or	Remote	Computer

1.	 Start	Little	Navmap	on	the	client	computer.
2.	 Open	the	connection	dialog	in	Little	Navmap	by	selecting		Main	Menu		->		Tools		->		Flight	Simulator	Connection	.

Usage
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Picture	above:	Connect	dialog	with	correct	values	to	access	the	_Little	Navconnect	shown	above._

3.	 Select		Connect	to	a	remote	Flight	Simulator	.

4.	 Add	the	value	for	hostname.	This	can	be	either	the	hostname	or	the	IP	address	printed	by	Little	Navconnect.
5.	 Check	the	value	for	the	port.		51968		is	the	default	value	and	does	not	need	to	be	changed	usually.
6.	 Click		Connect	.	The	dialog	will	close	and	Little	Navmap	will	try	to	establish	a	connection	in	the	background	which	can

take	some	time,	depending	on	your	network.	Your	aircraft	will	show	up	on	the	map	and	on	the		Simulator	Aircraft		dock
window	once	a	flight	is	set	up	and	loaded	on	the	simulator.	You	will	see	the	message		Connected.	Waiting	for	update.		in
the		Simulator	Aircraft		dock	window	if	no	flight	is	loaded	yet	(i.e.	the	simulator	still	shows	the	opening	screen).

Note	that	it	sometimes	can	take	a	while	until	an	error	is	shown	if	you	used	the	wrong	values	for	hostname	or	port.

Usage
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Menu	and	Options

	File	->	Quit

Exits	the	application.	Will	ask	for	confirmation	if	there	are	still	clients	connected.

Tools	->	FSX	or	Prepar3D	/	X-Plane

Chooses	the	simulator	connection.	These	functions	are	also	available	on	the	toolbar.

Tools	->	Reset	Messages

This	will	re-enable	all	dialogs	that	were	disabled	by	clicking		Do	not	show	this	dialog	again		or	similar	messages.

Tools	->	Toolbar

Shows	or	hides	the	toolbar.

	Tools	->	Options

Opens	the		Options		dialog	which	has	three	settings:

	Update	Time	Interval	:	Allowed	range	is	50	milliseconds	up	to	1	second.	Little	Navconnect	fetches	data	from	Flight
Simulator	and	sends	it	to	all	clients	(i.e.	Little	Navmap)	using	this	time	interval.	Increase	this	value	if	you	get	a	warning
message	like	shown	below:

	[2016-07-27	16:45:35]	Dropped	more	than	50	packages.	Reason:	Missing	reply.	Increase	update	time	interval.	

Dropped	packages	can	also	appear	if	the	Little	Navmap	cannot	respond	because	a	dialog	is	open.

	Network	Port	:	This	can	normally	be	left	at	default.	Change	this	value	only	if	another	application	occupies	this	port	and
you	get	an	error	message	like	shown	below	when	starting	Little	Navconnect:

	[2016-07-27	16:45:35]	Unable	to	start	the	server:	The	bound	address	is	already	in	use.	

	Fetch	AI	or	multiplayer	aircraft		and		Fetch	AI	or	multiplayer	ships	:	Disables	fetching	of	AI	vehicles	and	the	transfer
across	the	network.	This	can	be	useful	for	performance	reasons	if	you	use	large	amounts	of	AI	but	do	not	want	to	see
it	in	Little	Navmap.	Note	that	ship	AI	is	not	available	on	X-Plane.

	Hide	hostname	and	IP	in	log	window	:	Check	this	option	to	disable	printing	of	hostname	and	IP	address	on	startup.	This
can	be	useful	for	streaming	sessions	where	Little	Navconnect	window	is	visible	to	others.

Picture	above:	Little	Navconnect	Options	Dialog	with	default	settings.

Menu	and	Options
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	Help	Menu	->	Contents	(Online)

Shows	the	online	help	in	your	default	web	browser.

	Help	Menu	->	Contents	(Offline,	PDF)

Shows	the	offline	help	PDF	document	in	your	default	PDF	viewer.

	Help	Menu	->	About	Little	Navconnect

Shows	version	and	revision	number	for	Little	Navconnect,	also	contains	links	to	the	configuration	file,	log	file	and	the
author's	e-mail	addresses.

	Help	Menu	->	About	Qt

Information	about	the	Qt	application	framework	that	is	used	by	Little	Navconnect.

Menu	and	Options
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How	to	report	a	Bug
If	something	goes	wrong	send	me	Little	Navconnect's	log	file	and	configuration	file	which	both	can	be	located	in	the	about
dialog.	My	e-mail	address	is	shown	in	the	about	dialog	of	Little	Navconnect	as	well.	Please	compress	the	log	file	in	a	ZIP
archive.

Please	add	all	steps	that	are	necessary	to	reproduce	the	error.

If	you're	concerned	about	privacy	when	sending	log	files:	The	log	files	will	contain	all	paths	(like	your		Documents		directory)
which	will	also	include	your	username	as	a	part	of	the	path.	They	might	also	contain	your	computer's	name	IP	address	in
your	network.

In	no	case	file	names	from	anything	else	than	flight	simulator	scenery	or	configuration	files	are	included.	No	names	or
content	of	personal	files	is	included	in	the	log	files.

I'd	suggest	to	remove	this	information	if	you're	concerned	about	it.

I	strongly	recommend	to	send	the	log	files	using	a	private	forum	message	or	by	email	and	not	attach	them	to	forum	posts
where	they	are	publicly	visible.

Files

Windows

Log	files	of	Little	Navconnect	for	Windows	7/8/10	are	typically	stored	in	the	directory:

	C:\Users\YOURUSERNAME\AppData\Local\Temp	

The	program	keeps	three	log	files	and	rotates	these	on	each	startup.	So	you	can	find	up	to	three	logs:

	abarthel-little_navconnect.log	,		abarthel-little_navconnect.log.1		and		abarthel-little_navconnect.log.2	.

All	configuration	files	of	my	programs	for	Windows	7/8/10	are	typically	stored	in	the	directory:

	C:\Users\YOURUSERNAME\AppData\Roaming\ABarthel	

There	is	one	configuration	file	for	this	program:

	little_navconnect.ini	:	INI	style	configuration	file.	Text	file.

macOS	and	Linux

The	configuration	files	are	stored	in		$HOME/.config/ABarthel		on	macOS	and	Linux.	Log	files	are	stored	in		/tmp		on	Linux	and
in		/var/folders		on	macOS.

License
This	program	is	free	software:	you	can	redistribute	it	and/or	modify	it	under	the	terms	of	the	GNU	General	Public	License	as
published	by	the	Free	Software	Foundation,	either	version	3	of	the	License,	or	(at	your	option)	any	later	version.

This	program	is	distributed	in	the	hope	that	it	will	be	useful,	but	WITHOUT	ANY	WARRANTY;	without	even	the	implied
warranty	of	MERCHANTABILITY	or	FITNESS	FOR	A	PARTICULAR	PURPOSE.	See	the	GNU	General	Public	License	for
more	details.

You	should	have	received	a	copy	of	the	GNU	General	Public	License	along	with	this	program.	If	not,	see
http://www.gnu.org/licenses.
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