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0 – Introduction
This guide will show you how to create an aerial scenery in MSFS. 

Please do note that is tutorial will not show you how to install the prerequisites. It is also 
pretty much necessary to already have some knowledge of scenery development in MSFS.

We will be creating an aerial scenery for the airport ENFL - Florø Airport

0.1 – Prerequisites:

Ortho4XP by   Oscar Pilote   - Version as of writing is v130

QGIS   (  Standalone Installer  )  - Version as of writing is 3.14

tiles2bing by Christine Winther- Version as of writing is 0.0.2

MSFS SDK - Version as of writing is 0.5.1
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https://drive.google.com/file/d/1PWgp33gDUQbY3uZmYbTi3ccMPLIJMQAQ/view
http://winthers.net/files/tiles2bing.zip
https://qgis.org/en/site/forusers/download.html
https://qgis.org/en/site/forusers/download.html
https://qgis.org/en/site/forusers/download.html
https://qgis.org/en/site/forusers/download.html
https://drive.google.com/file/d/1PWgp33gDUQbY3uZmYbTi3ccMPLIJMQAQ/view
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1 – Setting up our project
Create a project folder if you don’t already have one.

It doesn’t matter where you place it, as long as the drive you are using has enough space. 

I recommend naming the folder with the airport name. 

NOTE: Do not use non-English letters in the name

Copy and paste the PackageSources folder from MSFS_SDK_LOCATION\Samples\
SimpleAerial to your project folder
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Delete the sample aerial images inside YOUR_PROJECT_FOLDER\PackageSources\CGL\
aerial_images

Create a folder for the .tif files we will be downloading via Ortho4XP

5 out of 40



How to create custom aerial scenery in MSFS by Augustin Winther v.1.1

2 – Downloading our aerial imagery
Open up Ortho4XP, and click on the world icon

Find the tile that you airport resides in.

Double click the left mouse button on the map to select a tile. The tile will receive a yellow 
border when selected. Once selected, exit out of the map window
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Back in the main menu of Ortho4XP, click the multicolored ZL icon

In the ZL windows, select a Preview source. This will be the background image in the ZL 
window, so that we have a reference on where we are selecting tiles..

Select Zoom level 13. The closer in we see the preview, the better precision we have with 
selecting tiles we want to download. After this, click preview
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Now you will see an aerial image of the tile we select in the preview window, to move 
around, hold down the right mouse button and drag. Time to find the airport.
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After some searching, I found my airport! As you can see it's quite small on the preview 
window (since I forgot to select zoom level 13).This is why having the Preview Zoom Level to 
13 is important!
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Now it's time to select which source we want to download from, and what ZL (Zoom Level, 
higher number, more crisper image and more disk space) we want. 

Use the source that has the best quality aerial imagery on your project location, and select a 
Zoom Level. I'm going to use ZL19 to get the best possible aerial image.

To select the tiles you want to download, Hold down CTRL and click the left mouse button. To 
delete a tile, hold down CTRL and press the right mouse button. Once you have selected your 
tiles, click on "Save zone", and "Apply". Finally click on "Make GeoTiffs". Note down 
how many tiles you have by height and width. In my case I have 3 tiles high, and 5 tiles width.
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You will then see in the main menu on Ortho4XP that the log is showing the downloading and 
converting of the aerial images

You can now exit out of Ortho4XP
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Copy the downloaded .tif files from ORTHO4XP_LOCATION\Geotiffs to your project 
folders .tif file folder we created earlier

I would also recommend to rename them for simplicity sake
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3 – Editing our aerial imagery

I'll start of by finding out what size my .tif files are. And I see that they are 4096x4096 px 
(Right click .tif file and select properties).

So I start up my preferred image editing software, GIMP. And I start a new image with 
4096px*3 for the height, and 4096px*5 for the width. 3 and 5 are the numbered we noted 
down when we selected tiles in the ZL window in Ortho4XP
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Now we need to configure the grid of our project
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Set the grid to 4096x4096 since that is the size of the .tif's
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Then enable "Show Grid" and "Snap Grid"
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Drag and drop the .tif file into Gimp. This pop-up window will show. Press "Import"

Make sure to align them correctly with the grid.
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To remove unwanted aerial photo, just erase it with the eraser

Remember to SAVE during your editing!

I will not cover color 
correcting since I do not 
have enough experience 
with that
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Once you happy with you edit, it's time to export it as a .png. 

REMEMBER to disable the white background in GIMP. You want the background of the image 
to be checkerboard, meaning it is transparent.

Go to File > Export As, and export it as .png (end the Name: with a ".png"). Click 
“Export”, and when another windows pops up, click “Export” again. Note, that it may take 
a few minutes, it's a lot of data. I’ll save mine as enfl_geo.png
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4 – Importing, georeferencing and exporting in QGIS
Open up QGIS, and right click on "XYZ Tiles", and click on "New Conecction" (If you 
don't see the "Browser" panel. Go to View > Panels > Browser and check the box )
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Select the reference map to use in QGIS (This will be the map we use to know where in the 
world we are) 

I’ll be using Bing, but you can use any of the ones listed below. Copy the link and paste it into 
the URL field in the XYZ Connection window, and give it a suitable name.

 OpenStreetMap:  http://tile.openstreetmap.org/{z}/{x}/{y}.png
 Bing Aerial:  http://ecn.t3.tiles.virtualearth.net/tiles/a{q}.jpeg?g=1
 Google Hybrid:  https://mt1.google.com/vt/lyrs=y&x={x}&y={y}&z={z}
 Google Satellite:  https://mt1.google.com/vt/lyrs=s&x={x}&y={y}&z={z}
 Google Road:  https://mt1.google.com/vt/lyrs=m&x={x}&y={y}&z={z}
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https://mt1.google.com/vt/lyrs=m&x=%7Bx%7D&y=%7By%7D&z=%7Bz%7D
https://mt1.google.com/vt/lyrs=s&x=%7Bx%7D&y=%7By%7D&z=%7Bz%7D
https://mt1.google.com/vt/lyrs=y&x=%7Bx%7D&y=%7By%7D&z=%7Bz%7D
http://ecn.t3.tiles.virtualearth.net/tiles/a%7Bq%7D.jpeg?g=1
http://tile.openstreetmap.org/%7Bz%7D/%7Bx%7D/%7By%7D.png
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Now, open up the XYZ Tiles tab, and right click the map you added in the last step and click 
on "Add Layer to Project"
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You should now see the map you chose in the preview window. Now you need to find the 
place you are creating an aerial scenery for
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Now we need to georeference the aerial image. Basically meaning we need to give it 
information on where it's coordinates in the world is.

Go to Raster > Georeferencer

Click on Open Raster (Blue and black checker-boarded icon) and select your final exported
.png. It may take a while for it to load
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When it's loaded click on the "Add Point" button. You will now see that the cursor turns into
a gray cross when you hover over the image.

Now, you need to find a reference point. A point that is easy to see on both the reference map 
you added, and your aerial imagery, and that is easy to be precise with, I will choose one of the
corners of the touchdown markings on the runway.

Left click on the point and a window will pop up. Click on "From Map Canvas" and basically 
left click on the same point on the map canvas, and click “OK”.
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You have now created your first georeference point. I recommend that you create quite a few 
of these to increase the accuracy. I'll be creating 20. You can remove points by selecting the 
icon to the right to the Add Point icon
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When you are done creating your points, click on "Start Georefrencing" (Green play 
button)

A little window will most likely pop up asking you to set the information type, click “OK”
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Another window will pop up, check that the settings in the picture below match yours. If not, 
change the settings accordingly. The output raster file name is up to you however. I will save it
in the same folder with all the other .tif files as enfl_geo_mod.tif

Click "Ok", and click on "Start Georeferencing" (Green play button) again.

It will now start to georeference the image!
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And tada! The image now has a geographical location! 

If the image is not placed correctly on the map, then you need to georeference again, and try to 
add reference points on other places

Now it's time to export it!
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Hide the other layers first by un-checking them so that out newly georeferenced layer is the 
only one showing
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Then we need to open up the Proccesing Tollbox. View > Panels > Proccesing 
Toolbox

31 out of 40



How to create custom aerial scenery in MSFS by Augustin Winther v.1.1

A new windows should appear. On it go to Raster tools > Genereate XYZ tiles 
(Directory)

Choose the newly georeferenced layer as Extent
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Set the Minimum and Maximum zoom to 19. And the output folder can be a folder in your 
Project folder called Tiles. So create that

Make sure your settings are correct and click “Run” to start the export. This will basically 
chop up the picture in to tiny squares which will we later convert to a structure that MSFS will 
understand
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When it's done, you'll find a folder in you Tiles folder named after you zoom level, and inside 
that folder is many other sub-folders, and inside them, are the pictures of your aerial imagery
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5 – tiles2bing
In your windows search bar type cmd and click om Command Prompt
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Now you need to type in cd followed by the path to where you have extracted tiles2bing, I have
mine in C:\Users\Augustin\Documents\MSFS - Tutorials\tiles2bing

(If you are wondering how to find the path to certain folders, open the folder up in File explorer, 
and click in the bar where it's says where you are)

Now that we are in the tiles2bing, we can start to convert the images we have in out "Tiles" 
folder.

Type the command tiles2bing "C:\Path\To\Tiles" /o "C:\Path\to\
PackageSources\CGL\aerial_images" /y google

Of course replace the \path\to\ with your respective path, for me it's this:

tiles2bing 

"C:\Users\Augustin\Documents\MSFS - Tutorials\ENFL – Floro Airport\Tiles" 

/o "C:\Users\Augustin\Documents\MSFS – Tutorials\ENFL – Floro Airport\PackageSources\CGL\aerial_images" 

/y google

Remember to use the Quotes (") at each end of the folder paths.
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If you get an error saying a .dll file is missing, install this: 
https://dotnet.microsoft.com/download/dotnet-core/thank-you/sdk-3.1.401-windows-x64-
installer 

When everything works smooth, the output should look like this

And the aerial_images folder should be full up on your aerial imagery
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https://dotnet.microsoft.com/download/dotnet-core/thank-you/sdk-3.1.401-windows-x64-installer
https://dotnet.microsoft.com/download/dotnet-core/thank-you/sdk-3.1.401-windows-x64-installer
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6 – Compiling
Start up MSFS and go to the place where you are to have your aerial imagery. Open up an existing 
project or create a new one.

Create a new CGL ssset

Set the AssetDir to the PackageSource\CGL folder, and the OutputDir to CGL\

Save the project, and open up the console window and clear it so that we can see all the info 
that comes up when we build the imagery
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This should be the output after you built your package if you’re only building a CGL asset 
(Only error is that we don't have any ContentInfo folder, but that's not a problem in our case)

You should now have a Packages folder in you project folder, and inside that folder is our 
newly built package!

Place this package in your MSFS Community folder and restart the sim, and go back to the 
location of the aerial imagery
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7 – THE FINAL RESULT

Before                                                                                            After

Hope this guide/tutorial helped you!

I would like to thank both the developers of QGIS, Oscar Pilote and Christine Winther for 
making the tools necessary for doing this! You are legends!
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