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Installing & Configuring 
Airport Design Editor 
“A journey of  a thousand miles begins with a single step.” 

elcome to Airport Design Editor Home Edition (ADE). ADE is an airport 
design tool for Microsoft Flight Simulator X (FSX) developed by The 
ScruffyDuck Software Company. ADE Home Edition was created with 
the beginner in mind because it allows new designers and enthusiasts to 

make significant changes to their local airports without the risk of making significant 
mistakes. Home Edition reduces the learning curve and makes airport design almost 
addictive.  Soon you will find yourself spending countless hours creating, tweaking, and 
testing features at your favorite airports. 

In this tutorial, you will learn how to properly install ADE 
Home Edition on your computer and how to configure it with 
your installation of the FSX Software Development Kit (SDK). 
Airport Design Editor will not work properly without the SDK. 
To obtain the SDK, you must purchase the Deluxe Edition of 
FSX because Microsoft does not make the SDK available via 
download. Once you purchase FSX Deluxe Edition, you will 
need to upgrade to the latest SDK version by visiting 
fsinsider.com. Another great resource for SDK-related 
information is fsdeveloper.com. 

ADE also requires Microsoft .NET Framework version 2.0.  Without .NET 2.0, ADE 
will not open. To obtain .NET 2.0, visit the Microsoft Download Center. 

Once you have the latest version of the SDK and .NET 2.0 installed on your 
computer, you are ready to install Airport Design Editor Home Edition. 

Tutorial 
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How to Install ADE 
While ADE Home Edition does not have an installer, installing the program is 
straight-forward.  To install the latest version of Home Edition follow the steps below: 

1. Download the latest version of ADE Home from 
airportdesigneditor.co.uk, avsim.net, scenery.org, flightsim.com, or 
simviation.net. The download consists of a zipped file folder. 

2. Once the download is complete, copy the contents of the zipped file, 
including sub-directories, to a new folder. 

3. Open your newly created folder and double-click on Airport Design 
Editor executable located inside of the Airport Design Editor folder. 
For easier access, you can make a shortcut to airport design 
editor.exe and copy it to your desk top. 

 

Windows XP 64-Bit / Vista Users: You may need to right-click on the 
ADE icon and select “Run as Administrator” for ADE to work 
properly on your computer. On some systems, Vista will not allow the 
user to access certain files/folders without first starting the program 
using “Run as Administrator.” 
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How to Setup ADE 
For Airport Design Editor to work properly, you will need to configure the program 
using the New User Wizard. The New User Wizard will automatically start when you 
first load ADE, but you can access the wizard anytime afterward by selecting New 
User Wizard from the Tools Menu. 

It is strongly recommended that you run through the New User Wizard to the end. 
You may cancel at any time, but ADE will not have all the information it needs to 
work correctly. If you do decide to cancel the wizard before finishing, then you can 
start the wizard again by following the procedures described above. 

The New User Wizard begins with the Welcome Screen. 

 
Figure 1 - ADE New User Wizard Welcome Screen  

This screen reminds you that it is important to completely configure ADE. Move to 
the General Options Screen by clicking Next. You can go back at any time and change 
or check things by clicking Back 

New User Wizard 
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The next screen is the General Options screen. 

 
Figure 2 - ADE New User Wizard General Options 

There are four options to configure on this screen: 

1. Enter your initials – ADE uses your initials when constructing file 
names for your airport projects. 

2. Message Timing – Select a time in seconds to display temporary 
messages. The standard is one or two seconds. Messages like File 
Saved etc. will then display for this time and close without you needing 
to do anything. You can set any time between one and five seconds in 
half second intervals. 

3. Auto Save – Select a time in minutes as the interval between auto-
saves. Five minutes is a good starting point, but you can set it to any 
time between one and 30 minutes in 30 second intervals. 

4. Parking & Apron Links – Parking & Apron Links should not show a 
surface type, but there is a bug in FSX that will allow this to happen. 
By selecting this option, ADE will manage Parking and Apron Link 
surfaces to ensure that the surface type for these links matches the 
underlying aprons. Unless you want to handle these surface 
assignments yourself, you should leave this checked. 
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The Paths and Database configuration screen is next, and is the most important 
section in the Wizard, so please take time to enter the correct information. 

 
Figure 3 - ADE New User Wizard Path & Database Configuration Screen 

ADE uses the latest version BglComp.exe from the FSX SDK. Please Note: For ADE 
to work properly, you will need the updated SDK from either the Service Packs (SP1 
or SP2) or the FSX Acceleration DVD. 

 

To select the location of 
BglComp, use the small 
button to the right of the 
FSX BglComp field.  
BglComp will be in the SDK 
folder under the 
Environment Kit sub-folder. 
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In addition to BglComp, Airport Design Editor needs to know the location of your 
main FSX installation. ADE uses this to gather and compile information about 
airports, navigational aids, and other objects near your airport. 

 

Use the small button to the 
right of the FSX field to get 
this location. It is the main 
FSX Folder – do not select 
any sub folder. Future 
versions of ADE may search 
the registry for the path but 
that is not yet implemented. 

 

 

 

 

 

Once you have properly configured the locations for BglComp and FSX, click the 
Scan button under the Database section. ADE will then create several databases of 
information from FSX. It does not search Add-on Scenery at this time. After a few 
moments you should see a progress bar and file names being listed. If this does not 
happen, then please check the FSX Folder location setting. 

Please be patient as this process may take a while. Depending on the speed of your PC 
the scan can take up to ten minutes to complete, but it usually only needs to be done 
once. Make sure that you wait until the Scan button becomes active again before 
moving on to the next page. 
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The final configuration screen is for Measurement Units.  

 
Figure 4 - ADE New User Wizard Measurement Configuration Screen 

There are five different units of measure that you will need to set based on your 
preferences: 

1. Distance – Refers to things that may be some way off or large. Navaid 
Ranges are a good example. The distance options are nautical miles 
(NM), feet, or meters. 

2. Dimension – Refers to smaller measurements like runway lengths and 
widths, guideline lengths, etc. You can choose either metric units 
(meters) or U.S. customary units (feet). 

3. Parking Radius – Parking Radius units are set separately. Most 
experienced airport designers use metric parking radius values even if 
other dimensions are set in feet. 

4. Altitude – Altitude can be set in meters or feet and is independent of 
Dimension units. Consequently, you can have altitude in feet, while 
runway lengths are in meters. 

5. Co-ordinates – There are several ways to describe geographical co-
ordinates today. At the moment, ADE only allows two formats: 
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Decimal (e.g. 23.4567, -125.789) and Degrees Decimal Minutes (e.g. 
N23 28.556, W125 47.223). 

Beyond the basic settings in the New User Wizard, there are other configuration 
settings found throughout ADE. 

  

The Program Options section under the Settings Menu contains several advanced 
ADE settings. 

 
Figure 5 - ADE Program General Options 

The first tab of options is similar to the wizard. The comments field should be left 
blank. The other fields should be familiar except the Locking Disables Editing check 
box and the Logging Level Selection Buttons. 

If the Locking Disables Editing Check Box is selected, then you will not be able to 
edit airport elements you have locked yourself. 

As of version 1.05, ADE now generates Logging Information to help diagnose 
problems. There are three levels of logging that can be set by the user. The default is 
Normal and should be used unless a problem is encountered. Levels of Detail and Full 
can be set if required. Full will generate a lot of information and should only be used 
when requested by ADE developers. 

ADE will remember the log level you have set from session to session. A log will be 
created in the application folder for each calendar month, using the name format 
ade_YYYYMM.log. This will roll over when 15,000 entries are reached. 

Program Options 
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Figure 6 – ADE Program Folder Options 

The Folders Options are those that you set in the New User Wizard. If you want to 
change these for any reason you can do so here or by using the New User Wizard 
again. 

 

 
Figure 7 - ADE Program Units Options 

The Units Options are the same settings you entered in the New User Wizard. 
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Figure 8 - ADE Program Parking Options 

The Parking Options Tab allows you to change the values that ADE will use for the 
default radius of parking spots. The values used by ADE are based on the FSX 
defaults. You should not change these radius values unless you understand how FSX 
uses them to assign aircraft parking. 

 

 
Figure 9 - ADE Program Image Options 

ADE can generate its own screen shot by selecting Save Image under the File Menu. 
The Image Options tab allows you to set the screen shot’s image format and to define 
how the file name should be constructed. You can either use the airport ICAO with or 
without the airport name or you can choose your own name. In both cases, you can set 
whether ADE will add an index at the end of the file name and what starting index to 
use. 

Once you have completed your changes, remember to click Save. 
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Color Options are also available under the Settings Menu. Using ADE’s Color Picker, 
you can customize how ADE displays each airport element. 

 

 

 

Under the Lock Menu, you can choose to enable Program-Level Locking for Aprons 
and/or Runways.  Once either is selected, you will not be able to move, delete, or edit 
the element until you unlock it using the Lock Menu. ADE saves these program-level 
lock settings and will keep them from session to session. 

 

 

Using the View Menu, you can select what airport elements you want ADE to display.  
By default, Hold Short Node Limits are not displayed. If you want them to appear, you 
will need to select them using the View Menu.  

 

.

Color Options 

Lock Menu 

View Menu 
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Common ADE Error Messages 
The following are common error messages that users may encounter when installing 
and/or configuring Airport Design Editor. If you receive an error message and the 
solution either is not found below or does not correct the problem, please report the 
error to The ScruffyDuck Software Company or on the ADE Forum at 
fsdeveloper.com.  Be sure to attach your log file along with your error message. 

 

 Problem – ADE did not detect .NET Framework 2.0 on your system. 

 Solution – You need to either install .NET 2.0 from the Microsoft Download 
Center or confirm that it is installed correctly on your system. .NET 
frameworks are not backward compatible; therefore, ADE will not work on 
your system if you have .NET 3.0 or 3.5, but not 2.0. 

 

 

 Problem – ADE did not find SimConnect (located in the FSX SDK). 
SimConnect allows ADE to connect directly to FSX while the simulator is 
running. 

.NET Framework 
Initialization Error 

Could not load file 
or assembly 
‘Microsoft.Flight 
Simulator.Simconn
ect’ 
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 Solution – You need to install the latest SDK version from either 
fsinsider.com or from the FSX Acceleration DVD. 

 

 

 Problem – Either ADE did not find your main FSX installation and could not 
locate any stock information or one or more of the ADE database files are 
corrupted. 

 Solution – The FSX installation path is usually set within the New User 
Wizard the first time you run ADE.  If you receive this error after completing 
the New User Wizard, you will need to go back and confirm you entered the 
right location for FSX.  You can do so by either selecting New User Wizard 
under the Tools Menu or by using the Folders Options Tab in Program 
Options under the Settings Menu. Make sure you follow the New User Wizard 
instructions given on page 6 of this tutorial. Once you confirm the correct 
path, select Scan, and ADE will create the databases. 

 

 

 Problem – ADE did not find BglComp in your FSX SDK installation. Either 
you do not have the FSX SDK installed or you entered the wrong location in 
the New User Wizard. 

 Solution – The BglComp path is usually set within the New User Wizard the 
first time you run ADE.  If you receive this error after completing the New 
User Wizard, you will need to go back and confirm you entered the right 

Missing Stock 
Database Files 

BglComp Folder 
Error 
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location for the BglComp Folder.  You can do so by either selecting New User 
Wizard under the Tools Menu or by using the Folders Options Tab in 
Program Options under the Settings Menu. Make sure you follow the New 
User Wizard instructions given on page 5 of this tutorial. 

 

 

 Problem – ADE did not find your main FSX installation. 

 Solution – The FSX installation path is usually set within the New User 
Wizard the first time you run ADE.  If you receive this error after completing 
the New User Wizard, you will need to go back and confirm you entered the 
right location for FSX.  You can do so by either selecting New User Wizard 
under the Tools Menu or by using the Folders Options Tab in Program 
Options under the Settings Menu. Make sure you follow the New User Wizard 
instructions given on page 6 of this tutorial. 

 

 Problem – These errors appear to only impact XP 64-Bit and Vista operating 
systems.  The error occurs when ADE is not able to access certain files/folders 
that are needed because the user does not have the proper rights. 

 Solution – So far the only solution has been to either grant yourself global 
admin rights by editing your registry or by selecting “Run as administrator” 

FS Folder Error 

Various CLR20r3 
Errors 
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when loading ADE. If you encounter this error, please report it to The 
ScruffyDuck Software Company or on the ADE Forum at fsdeveloper.com. 

 

 

 Problem – You are using the original FSX SDK BglComp executable, which 
does not allow you to compile fence objects.  

 Solution – Upgrade to the latest SDK version by visiting fsinsider.com, or by 
purchasing the FSX Acceleration DVD. See page 1 for more details. 

Compiler Output 
Error 


